iThemes Security und WP Rocket

WP Rocket ist kompatibel mit dem Plugin iThemes Security.

iThemes Security hat eine Option, um zu verhindern, dass Systemdateien beschreibbar sind (was ein sehr vernĂŒnftiges Security-Feature darstellt). WP Rocket benötigt allerdings Schreibrechte fĂŒr .htaccess und wp-config.php, sowie fĂŒr das Anlegen von advanced-cache.php und den Verzeichnissen cache und wp-rocket-config. Verzeichnisrechte sollten auf 755, 775 oder (bei bestimmten Hostern) sogar auf 777 gesetzt sein. Dateirechte sollten dem fĂŒr WordPress standardmĂ€ĂŸigen Wert 644 entsprechen.

Sobald du WP Rocket installierst, stelle sicher, dass die System Files Protection von iThemes Security deaktiviert ist:

Falls diese Option doch noch aktiv ist, wenn du WP Rocket aktivierst, kann der Cache nicht angelegt werden, und du siehst die folgende Fehlermeldung: